ADRESACJA_IP_2.pdf

(233 KB) Pobierz
Adresacja IP – czêœæ 2
Zaawansowana adresacja IPv4
MAN
Internet
LAN
...
LAN
LAN
...
Zagadnienia:
• podziałsieci na równe podsieci (RFC 950, 1985 r.)
• technologia VLSM (RFC 1009, 1987 r.)
• technologia CIDR (RFC 1517-1520, 1993 r.)
1
1466647.006.png
Podziałsieci IP na równe podsieci
LAN
Problem:
•firma dysponuje jednym adresem IP sieci
•jak zaplanować adresację IP, obejmującą sieci LAN kilku budynków firmy?
Rozwiązanie –podziałjednej sieci IP na kilka podsieci
2
1466647.007.png 1466647.008.png 1466647.009.png 1466647.001.png 1466647.002.png
Zasady:
• z części komputerowej zapożyczamy pewną liczbę bitów po to,
by „przedłużyć” część sieciową
• w zapożyczonej części numerujemy podsieci
• każda podsieć jest sama w sobie siecią IP, dlatego ma własne adresy szczególne
(adres sieci i rozgłoszeniowy)
• adresy podsieci należy wyodrębniać inną maską; podsieci mają maskę z liczbą
jedynek zwiększoną o liczbę zapożyczonych bitów
przed podziałem
S K
po podziale
nr podsieci
S zapożyczone bity
K
3
Podziałsieci IP na równe podsieci
1466647.003.png
Przykład
Podzielić sieć 150.10.0.0 z maską 255.255.0.0 (/16) na cztery podsieci, podając
w wyniku:
• adres i maskę każdej podsieci
• zakres adresów komputerów w każdej podsieci
• adres rozgłoszeniowy w każdej podsieci
Postępowanie:
1. Ustalamy, ile bitów należy zapożyczyć z części komputerowej.
Aby ponumerować cztery podsieci, potrzebujemy zapożyczyć dwa bity.
2. Numerujemy podsieci
Kombinacje zapożyczonych bitów stanowią numery kolejnych podsieci:
00 –numer pierwszej podsieci
01 –numer drugiej podsieci
10 –numer trzeciej podsieci
11 –numer czwartej podsieci.
4
1466647.004.png
Przykład
przed podziałem
S (16 bitów)
K (16 bitów)
po podziale
_ _
S (18 bitów)
K (14 bitów)
5
1466647.005.png
Zgłoś jeśli naruszono regulamin